[manjaro-dev] zfs support?

kendell clark coffeekingms at gmail.com
Sun Feb 21 06:13:13 CET 2016

Good enough for me. I'll turn zfs support on, but will add a note to our
docs to only use it as non critical filesystems for now. I'll also point
people to that archwiki page, thanks a lot for that, it's some fantastic
Kendell clark

Jonathon Fernyhough wrote:
> I don't know of any major issues with ZFS, and I haven't come across any
> since I started using it under Linux several years ago. However, I do
> not use it as a root file system - I only use it to add extra, specific,
> storage volumes (e.g. /home, /var/lib/docker). This also avoids any
> issues with ordering of modules during boot.
> There do seem to be issues enabling the ZFS+SPL modules on a 15.12 live
> image [1] which I think may be due to a change in kernel 4.1 since the
> live image version.
> When enabling ZFS for at-boot pools there are two important steps. One,
> `systemctl enable zfs`. Two, `zpool set cachefile=/etc/zfs/zpool.cache
> <pool>`. This is all detailed on the Arch wiki [2] which is well worth
> reading.
> J
> [1] https://forum.manjaro.org/index.php?topic=31251.0
> [2] https://wiki.archlinux.org/index.php/ZFS
> On 20/02/16 13:33, Philip Müller wrote:
>> Hi Jonathon,
>> can you check this and give Kendell some info regarding zfs, as you're
>> using it on your own machine on daily basis.
>> greez
>> Phil
>> Am 20.02.2016 um 12:50 schrieb kendell clark:
>>> hi all
>>> I'm considering adding zfs support to our new sonar image that will be
>>> released in the next couple of days. I have a couple of questions before
>>> I turn the support on. The last time I tried this, about a year or so
>>> ago, it had serious issues with the linux kernel's vfs layor, which
>>> means it caused linux to no longer be able to mount lots of other
>>> filesystems. If this has been fixed I'll gladly add in the kernel
>>> modules, but I want to make sure this doesn't happen before I do. I've
>>> already got the tools in place where linux can create and check zfs
>>> filesystems, but It can't yet mount them without the modules. Can anyone
>>> help me out, either by answering hear or pointing me to documentation I
>>> can read? I've tried a few google searches, but all I've turned up are
>>> forum posts, and I can't find an answer as to whether this still happens.
>>> Thanks for reading
>>> Kendell Clark
>>> _______________________________________________
>>> manjaro-dev mailing list
>>> manjaro-dev at manjaro.org
>>> http://lists.manjaro.org/mailman/listinfo/manjaro-dev
> _______________________________________________
> manjaro-dev mailing list
> manjaro-dev at manjaro.org
> http://lists.manjaro.org/mailman/listinfo/manjaro-dev

More information about the manjaro-dev mailing list