[manjaro-security] [ASA-201910-2] ruby: multiple issues

Levente Polyak anthraxx at archlinux.org
Thu Oct 3 21:14:42 CEST 2019

Arch Linux Security Advisory ASA-201910-2

Severity: Medium
Date    : 2019-10-02
CVE-ID  : CVE-2019-15845 CVE-2019-16201 CVE-2019-16254 CVE-2019-16255
Package : ruby
Type    : multiple issues
Remote  : Yes
Link    : https://security.archlinux.org/AVG-1039


The package ruby before version 2.6.5-1 is vulnerable to multiple
issues including arbitrary code execution, content spoofing, denial of
service and insufficient validation.


Upgrade to 2.6.5-1.

# pacman -Syu "ruby>=2.6.5-1"

The problems have been fixed upstream in version 2.6.5.




- CVE-2019-15845 (insufficient validation)

It has been discovered that Ruby before 2.4.8, 2.5.7 and 2.6.5 is
vulnerable to NUL injection in built-in methods (File.fnmatch and
File.fnmatch?). An attacker who has the control of the path pattern
parameter could exploit this vulnerability to make path matching pass
despite the intention of the program author.
The Built-in methods File.fnmatch and its alias File.fnmatch? accept
the path pattern as their first parameter. When the pattern contains
NUL character (\0), the methods recognize that the path pattern ends
immediately before the NUL byte. Therefore, a script that uses an
external input as the pattern argument, an attacker can make it wrongly
match a pathname that is the second parameter.

- CVE-2019-16201 (denial of service)

It has been discovered that Ruby before 2.4.8, 2.5.7 and 2.6.5 is
vulnerable to denial of service via regular expressions in WEBrick's
Digest access authentication module. An attacker can exploit this
vulnerability to cause an effective denial of service against a WEBrick

- CVE-2019-16254 (content spoofing)

It has been discovered that Ruby before 2.4.8, 2.5.7 and 2.6.5 is
vulnerable to HTTP response splitting in WEBrick bundled with Ruby. If
a program using WEBrick inserts untrusted input into the response
header, an attacker can exploit it to insert a newline character to
split a header, and inject malicious content to deceive clients.
This is the same issue as CVE-2017-17742. The previous fix was
incomplete, which addressed the CRLF vector, but did not address an
isolated CR or an isolated LF.

- CVE-2019-16255 (arbitrary code execution)

It has been discovered that Ruby before 2.4.8, 2.5.7 and 2.6.5 is
vulnerable to code injection. Shell#[] and its alias Shell#test defined
in lib/shell.rb allow code injection if the first argument (aka the
“command” argument) is untrusted data. An attacker can exploit this to
call an arbitrary Ruby method.


A remote attacker is able to bypass path restrictions, perform a denial
of service attack, inject malicious content or call an arbitrary Ruby
method under certain circumstances.



-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://lists.manjaro.org/pipermail/manjaro-security/attachments/20191003/76f0ace0/attachment.sig>

More information about the manjaro-security mailing list