[manjaro-general] Intel wifi (iwlwifi) can't be brought up after botched updated

Mittagskogel Dobratsch mittkog at gmail.com
Thu May 26 11:04:30 CEST 2022

Hi everyone,

Sorry to post this in the general mailing list. I've tried to sign up for
the forum, but regardless of which email I use (gmail, outlook, yahoo), I
get the following message:
"Something went wrong, perhaps this email is already registered, try the
forgot password link"
The message comes up instantly, so I doubt there is even a server request

Anyway, on to my main question:
Something went wrong during my last system upgrade on stable XFCE (linux
5.15). I believe the problem was an old version of the v4l2-loopback module
which prevented linux515-headers from building properly. To fix the issue,
I chrooted into my Manjaro partition from an old Lubuntu drive and rebuilt
the new 5.15 kernel and headers. From the looks of things, Manjaro now
works fine again, except for one small detail: the wifi interface (inxi -n:
Intel Dual Band Wireless-AC 3165 Plus Bluetooth) is permanently down, and I
cannot bring it up using the usual methods (ip link set wlp2s0 up, ifconfig
wlp2s0 up). Both commands exit without output, but the interface stays
down, as shown by ip addr.

rfkill list shows that everything is unblocked. I've tried to restart the
NetworkManager daemon. I cannot reload the iwlwifi module since it is in
use by iwlmvm. The output of nmcli dev status shows that wlp2s0 is

Any ideas where the issue might lie? I doubt it's a problem with the
iwlwifi driver itself, I've been using that for years without issue. I've
also booted the 5.10 kernel and tried installing the 5.17 kernel, but both
show the same issue.

Thanks for your help. I'm happy to continue the discussion in the forum if
someone can help me get signed up.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.manjaro.org/pipermail/manjaro-general/attachments/20220526/8ce46293/attachment.htm>

More information about the manjaro-general mailing list