[manjaro-general] /usr/share/application missing

Jonathon Fernyhough jonathon at manjaro.org
Fri Nov 17 18:48:27 CET 2017

On 17/11/17 02:26, Omid wrote:
> Hi
> I accidently moved a .desktop file to /usr/share/application with this
> command
> mv vim.desktop /usr/share/application
> Now i wanna update the system with pacman and i get "invalid or
> corrupted package (PGP signature)" error for each package after
> "checking package integrity"
> I used commands in this page but my problem not solved
> https://wiki.manjaro.org/index.php/Pacman_troubleshooting#Errors_about_Keys
> Please help me to solve this problem
> OS: Manjaro 17.0.6-EOL Gellivara
> Kernel: x86_64 Linux 4.9.47-1-rt37-MANJARO

You've probably already found this out, but the two things aren't
related at all. All you did was to move a file from one location to another.

On 17/11/17 03:59, Omid wrote:
> Hi again
> I solved update problem Now
> But still i don't know what is "/usr/share/application" file
> And i don't know what happends to my Manjaro with an empty
> "/usr/share/application" file
> Anway now everythings work
> What's your opinion?

`/usr/share/application` is not a file installed by any package in
Manjaro. You created it yourself when you moved the vim.desktop file there.

I assume you meant to move the file into `/usr/share/applications`,
which is where system-wide desktop application launchers are normally


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://lists.manjaro.org/pipermail/manjaro-general/attachments/20171117/f4152efe/attachment.sig>

More information about the manjaro-general mailing list