[manjaro-dev] new sonar-iso-profiles package needed?

kendell clark coffeekingms at gmail.com
Thu Jun 9 15:53:49 CEST 2016

Ok, after waiting nearly 2 hours for the mac to build my sonar mate
image, wow that took a while, lightdm still doesn't boot. So there's
definitely something wrong with it somewhere in our profile. The error
is still the same. 2 services allocated for the same bus
org.freedesktop.displaymanager, refusing operation. I'm wondering if the
problem might not be how the build tools are configuring lightdm and
it's corresponding plymouth service? The scripts are too complicated for
me to understand but it's a possibility.  I cloned a fresh copy of
manjaro-tools-iso-profiles on github on the mac, it had never had it
before, freshly installed manjaro-tools group, again, had never been
installed, copied over the manjaro-tools.conf file I have stored in the
sonar folder, changed the version slightly, and issued the following
command. sudo buildiso -p mate-edition -b unstable. So it can't just be
my machine or my particular copy of the iso profiles. Something's messed
up. Also, brltty is definitely restarting every couple of seconds. I
need to report this to the brltty people so they can fix it.
Kendell Clark

kendell clark wrote:
> hi
> I'm currently building a mate image on my mac. It's taking ages due to
> it's relatively slow dual core processor but I'm hoping it works better
> than the same image built on my more powerful desktop. If it doesn't
> I'll build your gnome profile.
> Thanks
> Kendell Clark
> kendell clark wrote:
>> hi all
>> I've been tearing my hair out trying to fix an apparently non existent
>> lightdm issue. Phil can make his builds work when using lightdm, I
>> cannot, no matter what I do. I've deleted and recloned the
>> manjaro-tools-iso-profiles directory numerous times. I see gdm in phil's
>> build log, he does not. I have lightdm in all profile.conf files, have
>> it in all packages files, and yet it will not start for me. I'm stumped,
>> completely.  The only profile without lightdm is gnome, which of course
>> has gdm. I've verified there are no gdm config files anywhere, and have
>> deleted all backup files created by my text editor, pluma. Nothing I try
>> works. I'm wondering if phil could push out an updated
>> sonar-iso-profiles package and I can try building using that? We're in
>> beta status, and I can't release an image where the display manager I
>> pick won't work. I haven't been able to test mate for bugs in the last
>> month. Does anyone know how I'd build an iso telling buildiso to use the
>> installed profiles instead of the ones in my home directory? I'd build
>> and upload a new sonar iso profiles package myself but I can't find the
>> pkgbuild in either the community or extra repository. Same for
>> sonar-common, which contains our desktop files and docs. I'd like to
>> start work on updating our documentation but I can't find the package
>> files to commit changes. Sorry to  sound so frantic, but I'm beginning
>> to wonder if a reinstallation of sonar from scratch might not be needed,
>> only my built images won't boot when using mate, which is my preferred
>> desktop so I can't. My system is acting so strangely, gstreamer
>> reporting it can't load backend libraries so I can't play half my music
>> files and videos, lightdm not working on built images on my system but
>> phil having no problems. I've reinstalled gstreamer, both versions
>> several times and I can't track down the problem. Last but not least, my
>> built images won't load when using uefi. Only the bios booting option
>> comes up and I'm pretty sure manjaro isn't having uefi issues.
>> Thanks
>> Kendell Clark

More information about the manjaro-dev mailing list